Coins Pro Cash Out - Stuck confirmation
Incident Report for Coins Pro
Resolved
This incident has been resolved.
Posted Aug 16, 2019 - 21:26 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Aug 16, 2019 - 15:59 GMT+08:00
This incident affected: Cash-in / Cash-out (Coins cash-out, Bank cash-out).