Coins Pro Cash Outs
Incident Report for Coins Pro
Resolved
This incident has been resolved.
Posted Nov 29, 2020 - 10:26 GMT+08:00
Update
We are continuing to investigate this issue.
Posted Nov 28, 2020 - 14:00 GMT+08:00
Update
We are continuing to investigate this issue.
Posted Nov 28, 2020 - 13:36 GMT+08:00
Investigating
We are currently experiencing issues in sending out confirmation links for Coins Pro cash outs to Coins.ph accounts. Our team is currently investigating on this.
Posted Nov 28, 2020 - 12:08 GMT+08:00
This incident affected: Cash-in / Cash-out (Coins cash-out).