Log in issues
Incident Report for Coins Pro
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 13:29 GMT+08:00
Update
We are continuing to investigate this issue.
Posted Jun 26, 2020 - 12:33 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Jun 26, 2020 - 12:30 GMT+08:00
This incident affected: Website (Log Ins) and Cash-in / Cash-out (Coins cash-in, Coins cash-out, Bank cash-out).