Coins Pro Trading
Incident Report for Coins Pro
Resolved
This incident has been resolved.
Posted Aug 20, 2019 - 21:10 GMT+08:00
Identified
A limited number of open orders submitted last July 26, 2019 may not appear under the Open Orders tab in the Trade View. Our team is working on returning the funds on hold for these cases.
Posted Jul 28, 2019 - 12:20 GMT+08:00
This incident affected: Website (Trading).